75
Validation results

Yoga Fit

Yoga Fit

WordPress 5.3.1 theme
75
  • THEME TYPEWordPress theme 5.3.1
  • FILE NAMEyoga-fit.zip
  • FILE SIZE15258885 bytes
  • MD56b7335d7fcb77c914e4c6d289d47310b
  • SHA1119003690c4811b1fa6dba876b17ad13f4b037c6
  • LICENSENone
  • FILES INCLUDEDCSS, PHP, XML, Bitmap images, Adobe Illustrator
  • THEME URIhttp://cmsmasters.net/yoga-fit/
  • VERSION1.1.9
  • AUTHOR URI
  • TAGSone-column, two-columns, three-columns, four-columns, left-sidebar, right-sidebar, custom-background, custom-colors, custom-header, custom-menu, editor-style, featured-image-header, featured-images, flexible-header, full-width-template, microformats, post-
  • CREATION DATE2019-10-25
  • LAST FILE UPDATE2019-10-25
  • LAST VALIDATION2019-10-25 16:55
  • OTHER VERSIONS

    1.2.4 : 77%

This theme seems to be proprietary. Themecheck doesn't distribute commercial themes.
Critical alerts
  1. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was cmsms-mega-menu.zip cmsms-content-composer.zip revslider.zip cmsms-contact-form-builder.zip layerslider.zip timetable.zip envato-market.zip.
Warning
  1. Text domain : Incorrect use of translation functions.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are yoga-fit, woocommerce, the-events-calendar, tribe-events-calendar-pro.
  2. Custom elements : Presence of custom headerNo reference to custom header was found in the theme.
  3. Custom elements : Presence of custom backgroundNo reference to custom background was found in the theme.
  4. I18N implementation : Proper use of _ex(Possible variable $ci found in translation function in twitteroauth.php. Translation function calls should not contain PHP variables.
  5. Screenshot : Screenshot fileBad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Static links : Presence of hard-coded linksPossible hard-coded links were found in the file template-functions.php.952: <a href='https://twitter.com/share' class='twitter-share-button' data-lang='en'><?phPossible hard-coded links were found in the file widgets.php.675: <label for='<?php echo esc_attr($this->get_field_id('user')); ?>'><?php esc_html_e('Flickr ID', 'yoga-fit'); ?> (<a href='http://www.idgettr.com' target='_blank'>idGettr</a>):<br />
  2. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  3. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  4. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  5. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  6. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  7. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  8. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  9. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  10. Use of includes : Use of include or requireThe theme appears to use include or require : theme-functions.php 984: require_once(ABSPATH . '/wp-admin/includes/file.php');1393: require_once(ABSPATH . '/wp-admin/includes/file.php');1419: require_once(ABSPATH . '/wp-admin/includes/file.php'); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : twitteroauth.php 16: require_once('OAuth.php'); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : plugin-activator.php 13: require_once(get_template_directory() . '/framework/class/class-tgm-plugin- If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : cmsms-theme-options.php 13: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-general.php');14: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-post.php');15: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-page.php');16: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-other.php');20: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-project.php');25: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-profile.php');30: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-campaign.php');31: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-donation.php');36: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-tt-event.php');40: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-product.php'); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : cmsms-theme-settings.php 20: require_once(CMSMS_SETTINGS . '/inc/cmsms-helper-functions.php');21: require_once(CMSMS_SETTINGS . '/cmsms-theme-settings-general.php');22: require_once(CMSMS_SETTINGS . '/cmsms-theme-settings-style.php');23: require_once(CMSMS_SETTINGS . '/cmsms-theme-settings-font.php');24: require_once(CMSMS_SETTINGS . '/cmsms-theme-settings-color.php');25: require_once(CMSMS_SETTINGS . '/cmsms-theme-settings-single.php');26: require_once(CMSMS_SETTINGS . '/cmsms-theme-settings-demo.php'); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes