97
Validation results

Rife Free

Free WordPress 5.2.1 theme

Rife Free

Free WordPress 5.2.1 theme
97
  • THEME TYPEWordPress theme 5.2.1
  • FILE NAMErife-free.2.3.8.zip
  • FILE SIZE2064469 bytes
  • MD58540ee8e8197cb52f63771f12e0169ec
  • SHA16abd6892cdd63387cc2622ed47b37e493fa2f658
  • LICENSEGNU GPL 3
  • FILES INCLUDEDCSS, PHP, HTML, XML, Bitmap images, Adobe Illustrator
  • THEME URIhttps://apollo13themes.com/rife/free/
  • VERSION2.3.8
  • AUTHOR URI
  • TAGSe-commerce, portfolio, photography, two-columns, three-columns, left-sidebar, right-sidebar, grid-layout, translation-ready, sticky-post, post-formats, custom-colors, custom-menu, featured-images, footer-widgets, full-width-template, theme-options, threade
  • CREATION DATE2019-04-30
  • LAST FILE UPDATE2019-04-30
  • LAST VALIDATION2019-04-30 20:49
This theme is open source.
Warning
  1. Custom elements : Presence of custom headerNo reference to custom header was found in the theme.
  2. Custom elements : Presence of custom backgroundNo reference to custom background was found in the theme.
  3. Screenshot : Screenshot fileBad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Static links : Presence of hard-coded linksPossible hard-coded links were found in the file apollo13-pages-functions.php.
    Ligne84: echo '<mark class='error'><span class='dashicons dashicons-no'></span> ' . sprintf( esc_html__( '%1$s - We recommend a minimum PHP version of 5.6. Having version 7 or higher is even better. See: %2$s', 'rife-free' ), esc_html( $php_version ), '<a href='https://docs.woocommerce.com/document/how-to-update-your-php-version/' targ
    Ligne88: echo '<mark class='warning'><span class='dashicons dashicons-warning'></span> ' . sprintf( esc_html__( '%1$s - We recommend a minimum PHP version of 5.6. Having version 7 or higher is even better. See: %2$s', 'rife-free' ), esc_html( $php_version ), '<a href='https://docs.woocommerce.com/document/how-to-update-your-php-version/' targ
    Ligne84: echo '<mark class='error'><span class='dashicons dashicons-no'></span> ' . sprintf( esc_html__( '%1$s - We recommend a minimum PHP version of 5.6. Having version 7 or higher is even better. See: %2$s', 'rife-free' ), esc_html( $php_version ), '<a href='https://docs.woocommerce.com/document/how-to-update-your-php-version/' targ
    Ligne88: echo '<mark class='warning'><span class='dashicons dashicons-warning'></span> ' . sprintf( esc_html__( '%1$s - We recommend a minimum PHP version of 5.6. Having version 7 or higher is even better. See: %2$s', 'rife-free' ), esc_html( $php_version ), '<a href='https://docs.woocommerce.com/document/how-to-update-your-php-version/' targ
    Ligne174: echo '<a href='https://apollo13themes.com/effective-image-optimization-makes-website-faste
    Ligne182: echo '<a href='https://apollo13themes.com/our-story-with-kinsta-hosting/'>'.esc_html__( 'R
    Ligne190: echo '<a href='https://apollo13themes.com/blog/'>'.esc_html__( 'Read more details on our B
    Ligne206: echo '<a href='https://apollo13themes.com/basic-elementor-plugin-tricks/'>'.esc_html__( 'R
    Ligne214: echo '<a href='https://apollo13themes.com/free-elementor-templates/'>'.esc_html__( 'Read m
    Possible hard-coded links were found in the file apollo13-pages.php.
    Ligne67: <h3 class='center'><a href='https://apollo13themes.com/rife/tutorials/'><?php echo esc_html__( 'Video T
    Ligne75: <h3 class='center'><a href='https://support.apollo13.eu/'><?php echo esc_html__( 'Support Forum', 'rife
    Ligne95: <h3 class='center'><a href='https://apollo13themes.com/contact/'><?php echo esc_html__( 'Contact Apollo
    Ligne97: echo '<a href='https://apollo13themes.com/contact/'>'.esc_html__( 'Just come and say hi :-
    Ligne95: <h3 class='center'><a href='https://apollo13themes.com/contact/'><?php echo esc_html__( 'Contact Apollo
    Ligne97: echo '<a href='https://apollo13themes.com/contact/'>'.esc_html__( 'Just come and say hi :-
    Ligne120: <h3 class='center'><a href='<?php echo esc_url('https://apollo13themes.com/rife/features/'); ?>'><?php echo esc_html__( 'Mo
    Ligne123: echo '<a href='https://apollo13themes.com/rife/features/'>'.esc_html__( 'Check what we hav
    Ligne126: <h3 class='center'><a href='<?php echo esc_url('https://apollo13themes.com/rife/designs/'); ?>'><?php echo esc_html__( 'Mor
    Ligne129: echo '<a href='https://apollo13themes.com/rife/designs/'>'.esc_html__( 'Check what you can
  2. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  3. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  4. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  5. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  6. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  7. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  8. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  9. Optional files : Presence of archive template file archive.phpThis theme does not contain optional file archive.php.
  10. Optional files : Presence of search results template file search.phpThis theme does not contain optional file search.php.
  11. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  12. Use of includes : Use of include or requireThe theme appears to use include or require : menu.php
    Ligne89: require_once( get_theme_file_path( 'advance/walkers/children-pages.php' ) )
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : header.php
    Ligne153: require_once( get_theme_file_path( 'advance/walkers/classic.php' ) );
    Ligne177: require_once( get_theme_file_path( 'advance/walkers/menu-pages.php' ) );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : core.php
    Ligne88: require_once( get_theme_file_path( 'advance/user-css.php') );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : rife.php
    Ligne9: require_once( get_theme_file_path( 'advance/rife_uni.php' ));
    Ligne70: require_once( get_theme_file_path( 'advance/inc/customizer/sections/class-a
    Ligne145: include_once( ABSPATH . 'wp-admin/includes/plugin.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : customizer.php
    Ligne212: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a
    Ligne213: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a
    Ligne214: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a
    Ligne215: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a
    Ligne216: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a
    Ligne217: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a
    Ligne218: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a
    Ligne219: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a
    Ligne230: require_once( get_theme_file_path( 'advance/inc/customizer/sanitization.php
    Ligne473: 'google_fonts' => file_exists($google_fonts_file)? require($google_fonts_file) : '',
    Ligne544: $classes = require_once( get_theme_file_path( 'advance/inc/font-awesome-icons' ));
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-apollo13-framework.php
    Ligne108: require_once( get_theme_file_path( 'advance/compatibility.php' ));
    Ligne117: require_once( get_theme_file_path( 'advance/customizer.php' ));
    Ligne129: require_once( get_theme_file_path( 'advance/admin/admin.php' ) );
    Ligne131: require_once( get_theme_file_path( 'advance/admin/metaboxes.php' ) );
    Ligne133: require_once( get_theme_file_path( 'advance/meta.php') );
    Ligne135: require_once( get_theme_file_path( 'advance/admin/print-options.php' ) );
    Ligne140: require_once( get_theme_file_path( 'advance/admin/apollo13-pages.php' ));
    Ligne142: require_once( get_theme_file_path( 'advance/admin/apollo13-pages-functions.
    Ligne147: require_once(get_theme_file_path( 'advance/cpt-admin.php'));
    Ligne151: require_once( get_theme_file_path( 'advance/inc/class-tgm-plugin-activation
    Ligne153: require_once( get_theme_file_path( 'advance/plugins/plugins-list.php' ) );
    Ligne164: require_once(get_theme_file_path( 'advance/head-scripts-styles.php'));
    Ligne181: require_once( get_theme_file_path( 'advance/utilities/core.php' ) );
    Ligne183: require_once( get_theme_file_path( 'advance/utilities/core_fe.php' ) );
    Ligne185: require_once( get_theme_file_path( 'advance/utilities/menu.php' ) );
    Ligne187: require_once( get_theme_file_path( 'advance/utilities/media.php' ) );
    Ligne189: require_once( get_theme_file_path( 'advance/utilities/posts.php' ) );
    Ligne191: require_once( get_theme_file_path( 'advance/utilities/layout-parts.php' ) )
    Ligne193: require_once( get_theme_file_path( 'advance/utilities/header.php' ) );
    Ligne195: require_once( get_theme_file_path( 'advance/utilities/footer.php' ) );
    Ligne197: require_once( get_theme_file_path( 'advance/utilities/password.php' ) );
    Ligne199: require_once( get_theme_file_path( 'advance/utilities/feature.php' ) );
    Ligne201: require_once( get_theme_file_path( 'advance/utilities/cpt.php' ) );
    Ligne203: require_once( get_theme_file_path( 'advance/utilities/cpt-album.php' ) );
    Ligne205: require_once( get_theme_file_path( 'advance/utilities/cpt-work.php' ) );
    Ligne207: require_once( get_theme_file_path( 'advance/utilities/cpt-people.php' ) );
    Ligne209: require_once( get_theme_file_path( 'advance/utilities/deprecated.php' ) );
    Ligne214: require_once( get_theme_file_path( 'advance/utilities/wpml.php' ) );
    Ligne219: require_once( get_theme_file_path( 'advance/utilities/woocommerce.php' ) );
    Ligne232: require_once( get_theme_file_path( 'advance/vc-extend.php' ) );
    Ligne238: require_once( get_theme_file_path( 'advance/elementor-pro.php' ) );
    Ligne243: require_once(get_theme_file_path( 'advance/sidebars.php'));
    Ligne673: require_once( get_theme_file_path( 'advance/theme-options.php') );
    Ligne693: require_once(get_theme_file_path( 'advance/meta.php'));
    Ligne1039: include_once( ABSPATH . 'wp-admin/includes/plugin.php' );
    Ligne1041: require_once(ABSPATH . '/wp-admin/includes/file.php');
    Ligne1042: require_once(ABSPATH . 'wp-admin/includes/template.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : admin.php
    Ligne137: $classes = require_once(get_theme_file_path( 'advance/inc/font-awesome-icons' ));
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : metaboxes.php
    Ligne190: require_once (get_theme_file_path( 'advance/meta.php' ));
    Ligne361: require_once (get_theme_file_path( 'advance/meta.php' ));
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes