55
Validation results

Olam

Olam

WordPress 6.1.1 theme
55
  • THEME TYPEWordPress theme 6.1.1
  • FILE NAMEolam.zip
  • FILE SIZE2397519 bytes
  • MD5f1e7d7942494811c6fcbc13ea5a531cb
  • SHA17b965a43f27f029523770ac0dd87a2b991a96828
  • LICENSEGNU GPL 2
  • FILES INCLUDEDCSS, PHP, HTML, Bitmap images
  • VERSION4.6.1
  • TAGScustom-colors,featured-images,theme-options
  • CREATION DATE2022-11-19
  • LAST FILE UPDATE2022-11-19
  • LAST VALIDATION2022-11-19 19:49
This theme seems to be proprietary. Themecheck doesn't distribute commercial themes.
Critical alerts
  1. Admin menu : Themes should use add_theme_page() for adding admin pages. File class-tgm-plugin-activation.php : 734: $this->page_hook = call_user_func( 'add_submenu_page', $args['parent_slug'], $args['page_title'], $args['menu_t
  2. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was olam-multiple-images.zip olam-edd-fes-meta-fields.zip layero-edd-related-downloads.zip.
Warning
  1. Text domain : Incorrect use of translation functions.Found a translation function that is missing a text-domain. Function __, with the arguments 'Last Backup : ' in file class.options_machine.php.Found a translation function that is missing a text-domain. Function _e, with the arguments 'Save All Changes' in file options.php.Found a translation function that is missing a text-domain. Function _e, with the arguments 'Options Reset' in file options.php.Found a translation function that is missing a text-domain. Function esc_html_e, with the arguments in file quick-contact.php.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are olam, easy-digital-downloads, cmb2, woocommerce, edd_fes, edd-wish-lists, edd-reviews, edd-rp-txt, eddslg.
  2. Hidden admin bar : Hidden admin Bar in CSSThemes should not hide admin bar. Detected in file style.css.
  3. I18N implementation : Proper use of _e(Possible variable $qctitle found in translation function in quick-contact.php. Translation function calls should not contain PHP variables.
  4. I18N implementation : Proper use of esc_html_e(Possible variable $qctitle found in translation function in quick-contact.php. Translation function calls should not contain PHP variables.
  5. Screenshot : Screenshot fileBad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  4. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  5. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  6. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  7. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  8. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  9. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  10. Use of includes : Use of include or requireThe theme appears to use include or require : index.php 73: require_once ( ADMIN_PATH . 'functions/functions.load.php' );74: require_once ( ADMIN_PATH . 'classes/class.options_machine.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : init.php 144: require_once 'includes/CMB2.php';145: require_once 'includes/helper-functions.php';151: require_once 'bootstrap.php'; If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : helper-functions.php 32: include_once( cmb2_dir( 'includes/{$class_name}.php' ) ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : functions.load.php 10: require_once( ADMIN_PATH . 'functions/functions.php' );11: require_once( ADMIN_PATH . 'functions/functions.filters.php' );12: require_once( ADMIN_PATH . 'functions/functions.interface.php' );13: require_once( ADMIN_PATH . 'functions/functions.options.php' );14: require_once( ADMIN_PATH . 'functions/functions.admin.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : functions.interface.php 80: include_once( ADMIN_PATH . 'front-end/options.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : header.php 35: if(isset($olamthemepreloader)&& $olamthemepreloader==1 ){ include('includes/preloader.php'); } ?> If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : color.css.php 9: require_once( $path_to_wp . 'wp-load.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes