0
Validation results

GrandNews

GrandNews

WordPress 5.5.3 theme
0
  • THEME TYPEWordPress theme 5.5.3
  • FILE NAMEgrandnews-v3.1.installable.zip
  • FILE SIZE3827546 bytes
  • MD525a42da966fbae073734fc8dd6018cf4
  • SHA1428c8a03005b6546b23613c41ded9c1d1631a996
  • LICENSEGNU GPL 2
  • FILES INCLUDEDCSS, PHP, HTML, XML, Bitmap images, Adobe Illustrator
  • THEME URIhttp://themes.themegoods.com/grandnews/landing
  • VERSION3.1
  • TAGSblack, white, responsive-layout, custom-header, custom-background, threaded-comments, translation-ready, editor-style, custom-menu
  • CREATION DATE2020-09-21
  • LAST FILE UPDATE2020-09-21
  • LAST VALIDATION2020-09-21 09:23
This theme seems to be proprietary. Themecheck doesn't distribute commercial themes.
Critical alerts
  1. Unwanted files : hidden file(s) or folder(s) .github .csslintrc .jshintrc .editorconfig .travis.yml .jscsrc .gitignore .simplecov .codeclimate.yml .jshintignore .coveralls.yml was found.
  2. Presence of iframes : iframes are sometimes used to load unwanted adverts and malicious code on another site Found <iframe src="//player.vimeo.com/video/'.$post_ft_vimeo.'?title=0&amp;byline=0&amp;portrait=0" width="670" height="377" frameborder="0"> in file template-post-header.php. 113: echo '<iframe src='//player.vimeo.com/video/'.$post_ft_vimeo.'?title=0&amp;bylineFound <iframe id="ppb_preview_frame" src="<?php echo esc_url($preview_url); ?> in file functions.php. 1460: <iframe id='ppb_preview_frame' src='<?php echo esc_url($preview_url); ?>'><
  3. Malware : Operations on file system file_get_contents was found in the file parsers.php 66: $success = $dom->loadXML( file_get_contents( $file ) );296: if ( ! xml_parse( $xml, file_get_contents( $file ), true ) ) {file_get_contents was found in the file parsers.php 66: $success = $dom->loadXML( file_get_contents( $file ) );296: if ( ! xml_parse( $xml, file_get_contents( $file ), true ) ) {fopen was found in the file parsers.php 442: $fp = $this->fopen( $file, 'r' );668: function fopen( $filename, $mode = 'r' ) {671: return fopen( $filename, $mode );fclose was found in the file parsers.php 491: $this->fclose($fp);686: function fclose( $fp ) {689: return fclose( $fp );fopen was found in the file parsers.php 442: $fp = $this->fopen( $file, 'r' );668: function fopen( $filename, $mode = 'r' ) {671: return fopen( $filename, $mode );fopen was found in the file parsers.php 442: $fp = $this->fopen( $file, 'r' );668: function fopen( $filename, $mode = 'r' ) {671: return fopen( $filename, $mode );fclose was found in the file parsers.php 491: $this->fclose($fp);686: function fclose( $fp ) {689: return fclose( $fp );fclose was found in the file parsers.php 491: $this->fclose($fp);686: function fclose( $fp ) {689: return fclose( $fp );
  4. Malware : Network operations curl_init was found in the file envato.lib.php 95: $ch = curl_init($url);curl_exec was found in the file envato.lib.php 106: $data = curl_exec($ch);
  5. Admin menu : Themes should use add_theme_page() for adding admin pages. File functions.php : 249: add_menu_page('Theme Setting', 'Theme Setting', 'administrator', 'functions
  6. Deprecated functions : screen_icon screen_icon found in file wordpress-importer.php. Deprecated since version 3.8.1118: screen_icon();
  7. Deprecated functions : wp_get_http wp_get_http found in file wordpress-importer.php. Deprecated since version 4.4. Use WP_Http instead.991: $headers = wp_get_http( $url, $upload['file'] );
  8. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was grandnews-custom-post.zip zilla-likes.zip posts-social-shares-count.zip.
Warning
  1. theme tags : Presence of bad theme tagsThe tag black has been deprecated, it must be removed from style.css header.The tag white has been deprecated, it must be removed from style.css header.The tag responsive-layout has been deprecated, it must be removed from style.css header.
  2. Text domain : Incorrect use of translation functions.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are grandnews, velvet-blues-update-urls, widget-importer-exporter, grandnews-translation, tgmpa, kirki, envato, wordpress-importer.
  3. Unwanted directories : GIT revision control directoryA.git was found.
  4. Custom elements : Presence of custom headerNo reference to custom header was found in the theme.
  5. Deprecated functions : screen_iconscreen_icon found in file wordpress-importer.php. Deprecated since version 3.8.1118: screen_icon();
  6. Editor style : Presence of editor styleNo reference to add_editor_style() was found in the theme. It is recommended that the theme implements editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  7. Featured image : Use of the_post_thumbnail() instead of custom fields for thumbnailsNo reference to the_post_thumbnail was found in the theme.
  8. Screenshot : Screenshot fileScreenshot size is 880x660px. Screenshot size should be 1200x900, to account for HiDPI displays. Any 4:3 image size is acceptable, but 1200x900 is preferred.Bad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  4. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  5. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  6. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  7. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  8. Use of includes : Use of include or requireThe theme appears to use include or require : config.lib.php 39: require_once(ABSPATH . 'wp-admin/includes/file.php'); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : admin.lib.php 145: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : js-wp-editor.php 35: require( ABSPATH . WPINC . '/class-wp-editor.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : responsive_css.php 24: require_once(get_template_directory().'/css/grid.css'); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : class-kirki-helper.php 83: require_once( ABSPATH . '/wp-admin/includes/file.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : class-kirki-control-fontawesome.php 42: include( $json_path ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : class-envato-wordpress-theme-upgrader.php 11: include_once( ABSPATH . 'wp-admin/includes/class-wp-upgrader.php' );13: include_once( 'class-envato-protected-api.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes