37
Validation results

CrazyBlog

CrazyBlog

WordPress 5.5.3 theme
37
  • THEME TYPEWordPress theme 5.5.3
  • FILE NAMEthemeforest-13233324-crazyblog-start-a-blog-or-magazine-for-adsense-or-affiliate-business-wordpress-theme.zip
  • FILE SIZE14014137 bytes
  • MD5ddd64a3c4925f47e6b39fbf4c9ee56ca
  • SHA19fbf1f46f1457368fe73f6b18d2ed7249a108fda
  • LICENSEGNU GPL 2
  • FILES INCLUDEDCSS, PHP, XML, Bitmap images, Adobe Illustrator
  • THEME URIhttp://themes.webinane.com/wp/crazy-blog
  • VERSION2.1.1
  • TAGSone-column, two-columns, right-sidebar, accessibility-ready, custom-background, custom-colors, custom-header, custom-menu, editor-style, featured-images, flexible-header, microformats, post-formats, rtl-language-support, sticky-post, threaded-comments, tra
  • CREATION DATE2020-04-25
  • LAST FILE UPDATE2020-04-25
  • LAST VALIDATION2020-04-25 20:00
This theme seems to be proprietary. Themecheck doesn't distribute commercial themes.
Critical alerts
  1. Presence of iframes : iframes are sometimes used to load unwanted adverts and malicious code on another site Found <iframe src="<?php echo esc_url( crazyblog_set( $recipeMeta, 'crazyblog_recipe_video' ) ) ?> in file featured_recipe.php. 56: <iframe src='<?php echo esc_url( crazyblog_set( $recipeMeta, 'crazyblog_recFound <iframe src="<?php echo esc_url( crazyblog_set( $meta_opt, 'crazyblog_post_video_link' ) ); ?> in file format-video.php. 17: <iframe src='<?php echo esc_url( crazyblog_set( $meta_opt, 'crazyblog_post_Found <iframe class="iframe-width" height="450" src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/' . crazyblog_set( $meta_opt, 'crazyblog_post_audio_link' ) . '&amp;auto_play=false&amp;hide_related=false&amp;show_comments=true&amp;show_user=true&amp;show_reposts=false&amp;visual=true"> in file format-audio.php. 26: <?php echo '<iframe class='iframe-width' height='450' src='https://w.soundcloud.com/pla
  2. Malware : Operations on file system file_put_contents was found in the file envato_setup.php 880: //file_put_contents( $zipfile, $body );
  3. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was layerslider.zip crazyblog-custom-plugin.zip.
Warning
  1. core scripts deregistered : Core scripts deregistrationFound wp_deregister_script in woocommerce.php. Themes must not deregister core scripts. 41: //wp_deregister_script( 'select2' );
  2. Text domain : Incorrect use of translation functions.Found a translation function that is missing a text-domain. Function esc_html__, with the arguments 'Style' in file envato_setup.php.Found a translation function that is missing a text-domain. Function esc_html__, with the arguments 'Enter the News Heading' in file news_ticker.php.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are crazyblog, lifeline2, bitco, samaan, eternity, flaky.
  3. Screenshot : Screenshot fileScreenshot size is 880x660px. Screenshot size should be 1200x900, to account for HiDPI displays. Any 4:3 image size is acceptable, but 1200x900 is preferred.Bad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. theme tags : Presence of bad theme tagsThemes that use the tag accessibility-ready will need to undergo an accessibility review.
    See https://make.wordpress.org/themes/handbook/review/accessibility/
  2. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  3. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  4. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  5. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  6. Use of includes : Use of include or requireThe theme appears to use include or require : envato_setup.php 654: include( 'envato-setup-export.php' );736: require_once( ABSPATH . 'wp-admin/includes/file.php' );844: require_once( ABSPATH . 'wp-admin/includes/file.php' );2156: require_once( ABSPATH . 'wp-admin/includes/file.php' );2181: require_once( ABSPATH . 'wp-admin/includes/file.php' );3229: require_once(ABSPATH . '/wp-admin/includes/file.php');3467: require_once(ABSPATH . '/wp-admin/includes/file.php');3476: include_once( ABSPATH . 'wp-content/plugins/crazyblog-custom-plugin/wordpre If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : bootstrap.php 9: require_once 'constant.php';14: require_once 'autoload.php'; If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : taxonomy.php 18: require_once 'classes/taxonomy.php'; If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : panel.php 9: require_once( crazyblog_ROOT . 'core/duffers_panel/panel/bootstrap.php' );10: include_once( crazyblog_ROOT . 'core/duffers_panel/extend/loader.php' );11: require_once( crazyblog_ROOT . 'core/duffers_panel/panel/admin/data_sources12: require_once( crazyblog_ROOT . 'core/application/library/vp_options.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : helpers.php 274: require_once(ABSPATH . 'wp-admin/includes/upgrade.php'); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : forms.php 310: include(ABSPATH . 'wp-includes/class-phpmailer.php'); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : import_export.php 16: require_once(ABSPATH . '/wp-admin/includes/file.php'); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : vp_options.php 92: require_once( crazyblog_ROOT . 'core/application/library/vp_options/' . $fi If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : widgets.php 41: require_once( $path ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : metabox.php 25: require_once( crazyblog_ROOT . 'core/duffers_panel/panel/bootstrap.php' );26: include_once( crazyblog_ROOT . 'core/duffers_panel/extend/loader.php' );27: require_once( crazyblog_ROOT . 'core/duffers_panel/panel/admin/data_sources If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : init.php 27: include(ABSPATH . 'wp-admin/includes/nav-menu.php'); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes