56
Validation results

ClassiadsPro

ClassiadsPro

WordPress 6.1.1 theme
56
  • THEME TYPEWordPress theme 6.1.1
  • FILE NAMEclassiadspro.zip
  • FILE SIZE6588642 bytes
  • MD5756123a5e080458a49600c8427f4f360
  • SHA1afbf8cb1ef8ee8c0ac07c606fb93e057f7defd9c
  • LICENSEGNU GPL 2
  • FILES INCLUDEDCSS, PHP, HTML, XML, Bitmap images, Adobe Illustrator
  • VERSION6.0.2
  • TAGStranslation-ready
  • CREATION DATE2022-10-27
  • LAST FILE UPDATE2022-10-27
  • LAST VALIDATION2022-10-27 18:44
  • OTHER VERSIONS

    5.9.3 : 56%

    5.5.7 : 0%

    5.4 : 0%

This theme seems to be proprietary. Themecheck doesn't distribute commercial themes.
Critical alerts
  1. Admin menu : Themes should use add_theme_page() for adding admin pages. File options-config.php : 67: // For a full list of options, visit: http://codex.wordpress.org/Function_Reference/add_submenu_page#Parameters
  2. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was collection5.zip.
Warning
  1. Hidden admin bar : Hidden admin Bar in CSSThemes should not hide admin bar. Detected in file classiadspro-dynamic.css.
  2. Editor style : Presence of editor styleNo reference to add_editor_style() was found in the theme. It is recommended that the theme implements editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  3. Date and time implementation : Use of the_time()At least one hard coded date was found in the file single.php. Function get_option( 'date_format' ) should be used instead.At least one hard coded date was found in the file grid_standard.php. Function get_option( 'date_format' ) should be used instead.At least one hard coded date was found in the file classic_standard.php. Function get_option( 'date_format' ) should be used instead.At least one hard coded date was found in the file published_date.php. Function get_option( 'date_format' ) should be used instead.
  4. Screenshot : Screenshot fileScreenshot size is 880x660px. Screenshot size should be 1200x900, to account for HiDPI displays. Any 4:3 image size is acceptable, but 1200x900 is preferred.
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  4. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  5. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  6. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  7. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  8. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  9. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  10. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  11. Use of includes : Use of include or requireThe theme appears to use include or require : pacz-admin.php 144: require_once( 'templates/plugins.php' );148: include_once( 'templates/icon-library.php' );153: include_once( 'templates/demo-import.php' );158: include_once( 'templates/tutorial.php' );162: require_once( 'templates/registration.php' );166: require_once( 'templates/theme-setup.php' );174: include_once( '_partials/performance.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : general.php 42: include($template);1004: require_once (ABSPATH . '/wp-admin/includes/file.php'); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : woocommerce.php 19: require_once (PACZ_THEME_PLUGINS_CONFIG . '/woocommerce-quantity-increment/ If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : metabox-layout.php 2: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : woocommerce-quantity-increment.php 98: require_once (trailingslashit( get_template_directory() ).'includes/plugins If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes