56
Validation results

Bosmarket

Bosmarket

WordPress 6.0.2 theme
56
  • THEME TYPEWordPress theme 6.0.2
  • FILE NAMEbosmarket.zip
  • FILE SIZE16961632 bytes
  • MD57f649b538a7ae5501b3e7650bad42e30
  • SHA1cbdd17dea458087737f41c5cf9fd9a679997da5a
  • LICENSEGNU GPL 2
  • FILES INCLUDEDCSS, PHP, XML, Bitmap images, Adobe Illustrator
  • DEMO PAGEhttp://demo.wpthemego.com/themes/sw_bosmarket/
  • VERSION2.0.11
  • TAGSrtl-language-support, sticky-post, two-columns
  • CREATION DATE2022-08-31
  • LAST FILE UPDATE2022-08-31
  • LAST VALIDATION2022-08-31 05:57
This theme seems to be proprietary. Themecheck doesn't distribute commercial themes.
Critical alerts
  1. Presence of iframes : iframes are sometimes used to load unwanted adverts and malicious code on another site Found <iframe width="560" height="315" src="https://www.youtube.com/embed/<?php echo esc_attr( $bosmarket_featured_video ); ?> in file content-quickview-product.php. 47: <iframe width='560' height='315' src='https://www.youtube.com/embed/<?php eFound <iframe width="560" height="315" src="https://www.youtube.com/embed/<?php echo esc_attr( $featured_video_product ); ?> in file utils.php. 1364: <iframe width='560' height='315' src='https://www.youtube.com/embed/<?php e
  2. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was sw_woocommerce.zip sw_ajax_woocommerce_search.zip sw_core.zip sw-product-bundles.zip sw_wooswatches.zip slideshow6.zip slide-home-12.zip slideshow8.zip slideshow7_1.zip slideshow11.zip slideshow2.zip slideshow7.zip slide-home-13.zip slideshow4.zip slideshow1.zip slideshow5.zip slideshow3.zip.
Warning
  1. Text domain : Incorrect use of translation functions.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are bosmarket, revo.
  2. Plugin territory : Plugin territory functionalitiesThe theme uses the add_shortcode() function. Custom post-content shortcodes are plugin-territory functionality.
  3. Date and time implementation : Use of date_i18n()At least one hard coded date was found in the file maintaince.php. Function get_option( 'date_format' ) should be used instead.At least one hard coded date was found in the file footer.php. Function get_option( 'date_format' ) should be used instead.
  4. Screenshot : Screenshot fileBad screenshot file extension ! File screenshot.png is not an actual PNG file. Detected type was : "image/jpeg".
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  4. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  5. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  6. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  7. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  8. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  9. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  10. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  11. Use of includes : Use of include or requireThe theme appears to use include or require : widget-product-categories.php 232: include_once( WC()->plugin_path() . '/includes/walkers/class-product-cat-li If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : nav.php 893: include( get_template_directory().'/lib/responsive_dropdown_sidebar.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : defines.php 20: require_once( get_template_directory().'/lib/options.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : currency-converter.php 308: include_once( get_template_directory(). '/lib/plugins/currency-converter/cu If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : activation.php 130: require_once ( get_template_directory().'/lib/plugin-requirement.php' ); 132: require_once ( get_template_directory().'/lib/import/sw-import.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : mobile-layout.php 5: require_once( get_template_directory().'/lib/mobile-detect.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : metabox.php 6: require_once( get_template_directory() . '/lib/metabox-category.php' ); If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : plugin-requirement.php 3: require_once( get_template_directory().'/lib/class-tgm-plugin-activation.ph If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.The theme appears to use include or require : widgets.php 11: include_once( get_template_directory() . '/widgets/woocommerce/widget-produ If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes