56
Résultats de validation

Woodmart

Woodmart

WordPress 5.3.2 theme
56
Ce thème n'est peut être pas libre. Themecheck ne distribue pas de thèmes commerciaux.
Alertes critiques
  1. Menu Admin : Les thèmes doivent utiliser add_theme_page () pour ajouter des pages admin. Fichier dashboard.php : 58: add_submenu_page(66: add_submenu_page(76: add_submenu_page(86: add_submenu_page(96: add_submenu_page(105: add_submenu_page(Fichier dashboard.php : 58: add_submenu_page(66: add_submenu_page(76: add_submenu_page(86: add_submenu_page(96: add_submenu_page(105: add_submenu_page(Fichier dashboard.php : 58: add_submenu_page(66: add_submenu_page(76: add_submenu_page(86: add_submenu_page(96: add_submenu_page(105: add_submenu_page(Fichier dashboard.php : 58: add_submenu_page(66: add_submenu_page(76: add_submenu_page(86: add_submenu_page(96: add_submenu_page(105: add_submenu_page(Fichier dashboard.php : 58: add_submenu_page(66: add_submenu_page(76: add_submenu_page(86: add_submenu_page(96: add_submenu_page(105: add_submenu_page(Fichier dashboard.php : 58: add_submenu_page(66: add_submenu_page(76: add_submenu_page(86: add_submenu_page(96: add_submenu_page(105: add_submenu_page(
  2. Inclusion de plugin : Présence de fichier zip Les plugins ne sont pas autorisés dans les thèmes. Le fichier zip revslider.zip woodmart-core.zip js_composer.zip woodmart.zip a été trouvé.
Attention
  1. Text domain : Utilisation incorrecte des fonctions de traduction.Plusieurs text-domain sont utilisés dans le thème. Cela signifie que le thème n'est pas compatible avec les language packs de WordPress. Les domaines trouvés sont woodmart, woocommerce, yith-woocommerce-wishlist.
  2. Eléments custom : Présence d'une entête customAucune référence à custom header n'a été trouvée dans le thème.
  3. Eléments custom : Présence d'un fond customAucune référence à custom background n'a été trouvée dans le thème.
  4. Screenshot : Copie d'écranMauvaise extension de fichier screenshot ! Le fichier screenshot.png n'est pas un véritable fichier JPG. Le type détecté est : "image/png".
Info
  1. présence de favicon : Gestion des faviconsDéclaration de favicon trouvée dans template-tags.php. Les favicons sont prises en charges dans le paramètrage Site Icon depuis la version 4.3.
  2. Fichiers optionnels : Présence du fichierde style pour les écritures de droite vers la gauche rtl.cssCe thème ne contient pas le fichier optionnel rtl.php.
  3. Fichiers optionnels : Présence du fichier-template fron-*page.phpCe thème ne contient pas le fichier optionnel front-page.php.
  4. Fichiers optionnels : Présence du fichier-template de catégorie category.phpCe thème ne contient pas le fichier optionnel category.php.
  5. Fichiers optionnels : Présence du fichier-template des tags tag.phpCe thème ne contient pas le fichier optionnel tag.php.
  6. Fichiers optionnels : Présence du fichier template de taxinomie taxonomy.phpCe thème ne contient pas le fichier optionnel taxonomy.php.
  7. Fichiers optionnels : Présence du fichier-template author.phpCe thème ne contient pas le fichier optionnel author.php.
  8. Fichiers optionnels : Présence de du fichier-template des dates et heures date.phpCe thème ne contient pas le fichier optionnel date.php.
  9. Fichiers optionnels : Présence du fichier-template des archives archive.phpCe thème ne contient pas le fichier optionnel archive.php.
  10. Fichiers optionnels : Présence du fichier-template des pièces jointes attachment.phpCe thème ne contient pas le fichier optionnel attachment.php.
  11. Fichiers optionnels : Présence du fichier-template des images image.phpCe thème ne contient pas le fichier optionnel image.php.
  12. Utilisation d'includes : Utilisation de include ou de de requireLe thème semble utiliser include ou require : Importversion.php 596: require_once($class_wp_importer); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : Vctemplates.php 318: require_once($class_wp_importer); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : template-tags.php 652: include_once( WC()->plugin_path() . '/includes/walkers/class-product-cat-li841: include_once( WC()->plugin_path() . '/includes/walkers/class-product-cat-li Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
Other checked themes