56
Résultats de validation

Trade

Trade

WordPress 4.6+ theme
56
  • TYPE DE THèMEThème WordPress %s 4.6+
  • NOM DU FICHIERtrade_V3.3.5.zip
  • TAILLE DU FICHIER12912943 octets
  • MD5e6bb4a40ad2a843f4af016d3d252d3ee
  • SHA16452469edcce9646f50a9b39668c12396450bc7e
  • LICENCEGNU GPL 2
  • FICHIERS INCLUSCSS, PHP, XML, Bitmap images, Adobe Illustrator
  • VERSION3.3.5
  • TAGStwo-columns, three-columns, left-sidebar, right-sidebar, custom-colors, custom-logo, editor-style, featured-images, front-page-post-form, full-width-template, theme-options, translation-ready
  • DATE DE CRéATION2020-06-30
  • DERNIèRE MISE à JOUR DU FICHIER2020-07-25
  • DERNIèRE VALIDATION2020-07-25 03:25
Ce thème n'est peut être pas libre. Themecheck ne distribue pas de thèmes commerciaux.
Alertes critiques
  1. Menu Admin : Les thèmes doivent utiliser add_theme_page () pour ajouter des pages admin. Fichier trade.options.php : 110: // For a full list of options, visit: http://codex.wordpress.org/Function_Reference/add_submenu_page#Parameters
  2. Inclusion de plugin : Présence de fichier zip Les plugins ne sont pas autorisés dans les thèmes. Le fichier zip trade-core.zip vc-ext-trade.zip js_composer.zip a été trouvé.
Attention
  1. tags du thème : Présence de tags inconnusTag inconnu custom-logo trouvé dans l'entête du fichier style.css.
  2. Text domain : Utilisation incorrecte des fonctions de traduction.Plusieurs text-domain sont utilisés dans le thème. Cela signifie que le thème n'est pas compatible avec les language packs de WordPress. Les domaines trouvés sont trade, axion.
  3. Implémentation de la date et de l'heure : Utilisation de the_time()Au moins une date codée en dur a été trouvée dans le fichier actions-config.php. Il est préférable d'utiliser la fonction get_option( 'date_format' )à la place.
  4. Screenshot : Copie d'écranMauvaise extension de fichier screenshot ! Le fichier screenshot.png n'est pas un véritable fichier PNG. Le type détecté est : "image/jpeg".
Info
  1. présence de favicon : Gestion des faviconsDéclaration de favicon trouvée dans actions-config.php. Les favicons sont prises en charges dans le paramètrage Site Icon depuis la version 4.3.
  2. Fichiers optionnels : Présence du fichierde style pour les écritures de droite vers la gauche rtl.cssCe thème ne contient pas le fichier optionnel rtl.php.
  3. Fichiers optionnels : Présence du fichier-template fron-*page.phpCe thème ne contient pas le fichier optionnel front-page.php.
  4. Fichiers optionnels : Présence du fichier-template de page d'accueil home.phpCe thème ne contient pas le fichier optionnel home.php.
  5. Fichiers optionnels : Présence du fichier-template de catégorie category.phpCe thème ne contient pas le fichier optionnel category.php.
  6. Fichiers optionnels : Présence du fichier-template des tags tag.phpCe thème ne contient pas le fichier optionnel tag.php.
  7. Fichiers optionnels : Présence du fichier template de taxinomie taxonomy.phpCe thème ne contient pas le fichier optionnel taxonomy.php.
  8. Fichiers optionnels : Présence de du fichier-template des dates et heures date.phpCe thème ne contient pas le fichier optionnel date.php.
  9. Fichiers optionnels : Présence du fichier-template des pièces jointes attachment.phpCe thème ne contient pas le fichier optionnel attachment.php.
  10. Fichiers optionnels : Présence du fichier-template des images image.phpCe thème ne contient pas le fichier optionnel image.php.
  11. Utilisation d'includes : Utilisation de include ou de de requireLe thème semble utiliser include ou require : actions-config.php 522: require_once(ABSPATH . 'wp-admin' . '/includes/image.php');523: require_once(ABSPATH . 'wp-admin' . '/includes/file.php');524: require_once(ABSPATH . 'wp-admin' . '/includes/media.php');536: require_once(ABSPATH . 'wp-admin' . '/includes/image.php');537: require_once(ABSPATH . 'wp-admin' . '/includes/file.php');538: require_once(ABSPATH . 'wp-admin' . '/includes/media.php'); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
Other checked themes