95
Résultats de validation

Rife Pro

Rife Pro

WordPress 5.7.1 theme
95
  • TYPE DE THèMEThème WordPress %s 5.7.1
  • NOM DU FICHIERrife.zip
  • TAILLE DU FICHIER3820953 octets
  • MD57f1cf83305c95a629f2d72a1309add2f
  • SHA19ced7bd098d7873056c2be413370d750db14bd26
  • LICENCEGNU GPL 3
  • FICHIERS INCLUSCSS, PHP, HTML, XML, Bitmap images, Adobe Illustrator
  • URI DU THèME URIhttps://apollo13themes.com/rife/
  • VERSION2.4.1
  • URI DE L'AUTEUR
  • TAGSe-commerce, portfolio, photography, two-columns, three-columns, left-sidebar, right-sidebar, grid-layout, translation-ready, sticky-post, post-formats, custom-colors, custom-menu, featured-images, footer-widgets, full-width-template, theme-options, threade
  • DATE DE CRéATION2019-07-18
  • DERNIèRE MISE à JOUR DU FICHIER2019-07-18
  • DERNIèRE VALIDATION2019-07-18 23:39
Ce thème n'est peut être pas libre. Themecheck ne distribue pas de thèmes commerciaux.
Attention
  1. Text domain : Utilisation incorrecte des fonctions de traduction.Mauvaus répertoire d'installation pour le thème. Le nom du répertoir doit correspondre au slug du thème. Le slug de ce thème ainsi que le text-domain est rife-pro.
  2. Text domain : Utilisation incorrecte des fonctions de traduction.Une fonction de traduction utilisée sans text-domain. Fonction esc_html__, avec les arguments 'Active to' dans le fichier rife_admin.php.
  3. Eléments custom : Présence d'une entête customAucune référence à custom header n'a été trouvée dans le thème.
  4. Eléments custom : Présence d'un fond customAucune référence à custom background n'a été trouvée dans le thème.
  5. Screenshot : Copie d'écranMauvaise extension de fichier screenshot ! Le fichier screenshot.png n'est pas un véritable fichier JPG. Le type détecté est : "image/png".
Info
  1. Liens statiques : Présence de liens codés en durLien potentiellement codés en dur trouvé dans le fichier rife_admin.php.332: echo '<li><p><a href='https://apollo13themes.com/rife/'>'. esc_html__( 'Get a new license', 'rife344: echo '<li><p><a href='https://apollo13themes.com/rife/'>'. esc_html__( 'Get a new license', 'rife455: echo '<a href='https://apollo13themes.com/rife/reviews/#add-review' target='_blank'>'.esc_333: echo '<li><p><a href='https://apollo13themes.com/contact/'>'. esc_html__( 'Contact Apollo13Themes345: echo '<li><p><a href='https://apollo13themes.com/contact/'>'. esc_html__( 'Contact Apollo13Themes332: echo '<li><p><a href='https://apollo13themes.com/rife/'>'. esc_html__( 'Get a new license', 'rife344: echo '<li><p><a href='https://apollo13themes.com/rife/'>'. esc_html__( 'Get a new license', 'rife455: echo '<a href='https://apollo13themes.com/rife/reviews/#add-review' target='_blank'>'.esc_333: echo '<li><p><a href='https://apollo13themes.com/contact/'>'. esc_html__( 'Contact Apollo13Themes345: echo '<li><p><a href='https://apollo13themes.com/contact/'>'. esc_html__( 'Contact Apollo13ThemesLien potentiellement codés en dur trouvé dans le fichier apollo13-pages-functions.php.84: echo '<mark class='error'><span class='dashicons dashicons-no'></span> ' . sprintf( esc_html__( '%1$s - We recommend a minimum PHP version of 5.6. Having version 7 or higher is even better. See: %2$s', 'rife' ), esc_html( $php_version ), '<a href='https://docs.woocommerce.com/document/how-to-update-your-php-version/' targ88: echo '<mark class='warning'><span class='dashicons dashicons-warning'></span> ' . sprintf( esc_html__( '%1$s - We recommend a minimum PHP version of 5.6. Having version 7 or higher is even better. See: %2$s', 'rife' ), esc_html( $php_version ), '<a href='https://docs.woocommerce.com/document/how-to-update-your-php-version/' targ84: echo '<mark class='error'><span class='dashicons dashicons-no'></span> ' . sprintf( esc_html__( '%1$s - We recommend a minimum PHP version of 5.6. Having version 7 or higher is even better. See: %2$s', 'rife' ), esc_html( $php_version ), '<a href='https://docs.woocommerce.com/document/how-to-update-your-php-version/' targ88: echo '<mark class='warning'><span class='dashicons dashicons-warning'></span> ' . sprintf( esc_html__( '%1$s - We recommend a minimum PHP version of 5.6. Having version 7 or higher is even better. See: %2$s', 'rife' ), esc_html( $php_version ), '<a href='https://docs.woocommerce.com/document/how-to-update-your-php-version/' targ174: echo '<a href='https://apollo13themes.com/effective-image-optimization-makes-website-faste182: echo '<a href='https://apollo13themes.com/our-story-with-kinsta-hosting/'>'.esc_html__( 'R190: echo '<a href='https://apollo13themes.com/blog/'>'.esc_html__( 'Read more details on our B206: echo '<a href='https://apollo13themes.com/basic-elementor-plugin-tricks/'>'.esc_html__( 'R214: echo '<a href='https://apollo13themes.com/free-elementor-templates/'>'.esc_html__( 'Read mLien potentiellement codés en dur trouvé dans le fichier apollo13-pages.php.42: <h3 class='center'><a href='https://support.apollo13.eu/'><?php echo esc_html__( 'Support Forum', 'rife57: <h3 class='center'><a href='https://apollo13themes.com/rife/tutorials/'><?php echo esc_html__( 'Video T65: <h3 class='center'><a href='https://apollo13themes.com/contact/'><?php echo esc_html__( 'Contact Apollo67: echo '<a href='https://apollo13themes.com/contact/'>'.esc_html__( 'Just come and say hi :-65: <h3 class='center'><a href='https://apollo13themes.com/contact/'><?php echo esc_html__( 'Contact Apollo67: echo '<a href='https://apollo13themes.com/contact/'>'.esc_html__( 'Just come and say hi :-
  2. Fichiers optionnels : Présence du fichierde style pour les écritures de droite vers la gauche rtl.cssCe thème ne contient pas le fichier optionnel rtl.php.
  3. Fichiers optionnels : Présence du fichier-template de page d'accueil home.phpCe thème ne contient pas le fichier optionnel home.php.
  4. Fichiers optionnels : Présence du fichier-template de catégorie category.phpCe thème ne contient pas le fichier optionnel category.php.
  5. Fichiers optionnels : Présence du fichier-template des tags tag.phpCe thème ne contient pas le fichier optionnel tag.php.
  6. Fichiers optionnels : Présence du fichier template de taxinomie taxonomy.phpCe thème ne contient pas le fichier optionnel taxonomy.php.
  7. Fichiers optionnels : Présence du fichier-template author.phpCe thème ne contient pas le fichier optionnel author.php.
  8. Fichiers optionnels : Présence de du fichier-template des dates et heures date.phpCe thème ne contient pas le fichier optionnel date.php.
  9. Fichiers optionnels : Présence du fichier-template des archives archive.phpCe thème ne contient pas le fichier optionnel archive.php.
  10. Fichiers optionnels : Présence du fichier-template des résultats de recherche search.phpCe thème ne contient pas le fichier optionnel search.php.
  11. Fichiers optionnels : Présence du fichier-template des images image.phpCe thème ne contient pas le fichier optionnel image.php.
  12. Utilisation d'includes : Utilisation de include ou de de requireLe thème semble utiliser include ou require : menu.php 89: require_once( get_theme_file_path( 'advance/walkers/children-pages.php' ) ) Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : feature.php 214: require_once( get_theme_file_path( 'advance/walkers/top-bar.php' ) );340: require_once( get_theme_file_path( 'advance/walkers/overlay.php' ) ); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : header.php 203: require_once( get_theme_file_path( 'advance/walkers/left-right.php' ) );208: require_once( get_theme_file_path( 'advance/walkers/left-right-no-menu.php'218: require_once( get_theme_file_path( 'advance/walkers/left-right.php' ) );223: require_once( get_theme_file_path( 'advance/walkers/left-right-no-menu.php'230: require_once( get_theme_file_path( 'advance/walkers/classic.php' ) );255: require_once( get_theme_file_path( 'advance/walkers/menu-pages.php' ) ); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : footer.php 304: include( $file_path ); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : core.php 88: require_once( get_theme_file_path( 'advance/user-css.php') ); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : rife.php 45: require_once( get_theme_file_path( 'advance/rife_uni.php' ));49: require_once( get_theme_file_path( 'advance/inc/pro/pro_admin.php' ));51: require_once( get_theme_file_path( 'advance/inc/pro/rife_admin.php' ));55: require_once( get_theme_file_path( 'advance/inc/pro/pro_fe.php' ));62: require_once( get_theme_file_path( 'advance/inc/theme-update-checker.php' ) Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : plugins-list_rife.php 4: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : plugins-list.php 68: require_once(get_theme_file_path( 'advance/plugins/envy-plugins.php' ));73: require_once(get_theme_file_path( 'advance/plugins/plugins-list_'.A13FRAMEW Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : customizer.php 221: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a222: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a223: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a224: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a225: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a226: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a227: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a228: require_once( get_theme_file_path( 'advance/inc/customizer/controls/class-a239: require_once( get_theme_file_path( 'advance/inc/customizer/sanitization.php482: 'google_fonts' => file_exists($google_fonts_file)? require($google_fonts_file) : '',553: $classes = require_once( get_theme_file_path( 'advance/inc/font-awesome-icons' )); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : class-apollo13-framework.php 108: require_once( get_theme_file_path( 'advance/compatibility.php' ));117: require_once( get_theme_file_path( 'advance/customizer.php' ));129: require_once( get_theme_file_path( 'advance/admin/admin.php' ) );131: require_once( get_theme_file_path( 'advance/admin/metaboxes.php' ) );133: require_once( get_theme_file_path( 'advance/meta.php') );135: require_once( get_theme_file_path( 'advance/admin/print-options.php' ) );140: require_once( get_theme_file_path( 'advance/admin/apollo13-pages.php' ));142: require_once( get_theme_file_path( 'advance/admin/apollo13-pages-functions.147: require_once(get_theme_file_path( 'advance/cpt-admin.php'));151: require_once( get_theme_file_path( 'advance/inc/class-tgm-plugin-activation153: require_once( get_theme_file_path( 'advance/plugins/plugins-list.php' ) );164: require_once(get_theme_file_path( 'advance/head-scripts-styles.php'));181: require_once( get_theme_file_path( 'advance/utilities/core.php' ) );183: require_once( get_theme_file_path( 'advance/utilities/core_fe.php' ) );185: require_once( get_theme_file_path( 'advance/utilities/menu.php' ) );187: require_once( get_theme_file_path( 'advance/utilities/media.php' ) );189: require_once( get_theme_file_path( 'advance/utilities/posts.php' ) );191: require_once( get_theme_file_path( 'advance/utilities/layout-parts.php' ) )193: require_once( get_theme_file_path( 'advance/utilities/header.php' ) );195: require_once( get_theme_file_path( 'advance/utilities/footer.php' ) );197: require_once( get_theme_file_path( 'advance/utilities/password.php' ) );199: require_once( get_theme_file_path( 'advance/utilities/feature.php' ) );201: require_once( get_theme_file_path( 'advance/utilities/cpt.php' ) );203: require_once( get_theme_file_path( 'advance/utilities/cpt-album.php' ) );205: require_once( get_theme_file_path( 'advance/utilities/cpt-work.php' ) );207: require_once( get_theme_file_path( 'advance/utilities/cpt-people.php' ) );209: require_once( get_theme_file_path( 'advance/utilities/deprecated.php' ) );214: require_once( get_theme_file_path( 'advance/utilities/wpml.php' ) );219: require_once( get_theme_file_path( 'advance/utilities/woocommerce.php' ) );232: require_once( get_theme_file_path( 'advance/vc-extend.php' ) );238: require_once( get_theme_file_path( 'advance/elementor-pro.php' ) );243: require_once(get_theme_file_path( 'advance/sidebars.php'));673: require_once( get_theme_file_path( 'advance/theme-options.php') );693: require_once(get_theme_file_path( 'advance/meta.php'));1039: include_once( ABSPATH . 'wp-admin/includes/plugin.php' );1041: require_once(ABSPATH . '/wp-admin/includes/file.php');1042: require_once(ABSPATH . 'wp-admin/includes/template.php'); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : admin.php 137: $classes = require_once(get_theme_file_path( 'advance/inc/font-awesome-icons' )); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : metaboxes.php 190: require_once (get_theme_file_path( 'advance/meta.php' ));361: require_once (get_theme_file_path( 'advance/meta.php' )); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : left-right.php 3: require_once( get_theme_file_path( 'advance/walkers/classic.php' ) ); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
Other checked themes