0
Résultats de validation

GrandNews

GrandNews

WordPress 5.5.1 theme
0
  • TYPE DE THèMEThème WordPress %s 5.5.1
  • NOM DU FICHIERgrandnews-v3.1.installable.zip
  • TAILLE DU FICHIER3827546 octets
  • MD525a42da966fbae073734fc8dd6018cf4
  • SHA1428c8a03005b6546b23613c41ded9c1d1631a996
  • LICENCEGNU GPL 2
  • FICHIERS INCLUSCSS, PHP, HTML, XML, Bitmap images, Adobe Illustrator
  • URI DU THèME URIhttp://themes.themegoods.com/grandnews/landing
  • VERSION3.1
  • TAGSblack, white, responsive-layout, custom-header, custom-background, threaded-comments, translation-ready, editor-style, custom-menu
  • DATE DE CRéATION2020-09-21
  • DERNIèRE MISE à JOUR DU FICHIER2020-09-21
  • DERNIèRE VALIDATION2020-09-21 09:23
Ce thème n'est peut être pas libre. Themecheck ne distribue pas de thèmes commerciaux.
Alertes critiques
  1. Fichiers indésirables : fichiers ou dossiers cachés .github .csslintrc .jshintrc .editorconfig .travis.yml .jscsrc .gitignore .simplecov .codeclimate.yml .jshintignore .coveralls.yml a été trouvé.
  2. Présence d'iframes : Les iframes sont parfois utilisées pour charger du contenu non désirés ou du code malicieux sur des sites tiers <iframe src="//player.vimeo.com/video/'.$post_ft_vimeo.'?title=0&amp;byline=0&amp;portrait=0" width="670" height="377" frameborder="0"> trouvé dans le fichier template-post-header.php. 113: echo '<iframe src='//player.vimeo.com/video/'.$post_ft_vimeo.'?title=0&amp;byline<iframe id="ppb_preview_frame" src="<?php echo esc_url($preview_url); ?> trouvé dans le fichier functions.php. 1460: <iframe id='ppb_preview_frame' src='<?php echo esc_url($preview_url); ?>'><
  3. Code malveillant : Opérations sur système de fichiers file_get_contents trouvé dans le fichier parsers.php. 66: $success = $dom->loadXML( file_get_contents( $file ) );296: if ( ! xml_parse( $xml, file_get_contents( $file ), true ) ) {file_get_contents trouvé dans le fichier parsers.php. 66: $success = $dom->loadXML( file_get_contents( $file ) );296: if ( ! xml_parse( $xml, file_get_contents( $file ), true ) ) {fopen trouvé dans le fichier parsers.php. 442: $fp = $this->fopen( $file, 'r' );668: function fopen( $filename, $mode = 'r' ) {671: return fopen( $filename, $mode );fclose trouvé dans le fichier parsers.php. 491: $this->fclose($fp);686: function fclose( $fp ) {689: return fclose( $fp );fopen trouvé dans le fichier parsers.php. 442: $fp = $this->fopen( $file, 'r' );668: function fopen( $filename, $mode = 'r' ) {671: return fopen( $filename, $mode );fopen trouvé dans le fichier parsers.php. 442: $fp = $this->fopen( $file, 'r' );668: function fopen( $filename, $mode = 'r' ) {671: return fopen( $filename, $mode );fclose trouvé dans le fichier parsers.php. 491: $this->fclose($fp);686: function fclose( $fp ) {689: return fclose( $fp );fclose trouvé dans le fichier parsers.php. 491: $this->fclose($fp);686: function fclose( $fp ) {689: return fclose( $fp );
  4. Code malveillant : Opérations réseau curl_init trouvé dans le fichier envato.lib.php. 95: $ch = curl_init($url);curl_exec trouvé dans le fichier envato.lib.php. 106: $data = curl_exec($ch);
  5. Menu Admin : Les thèmes doivent utiliser add_theme_page () pour ajouter des pages admin. Fichier functions.php : 249: add_menu_page('Theme Setting', 'Theme Setting', 'administrator', 'functions
  6. Fonctions obsolètes : screen_icon screen_icon trouvé dans le fichier wordpress-importer.php . Obsolète depuis la version de la 3.8. 1118: screen_icon();
  7. Fonctions obsolètes : wp_get_http wp_get_http trouvé dans le fichier wordpress-importer.php . Obsolète depuis la version de la 4.4. Il est prérable d'utiliser WP_Http à la place. 991: $headers = wp_get_http( $url, $upload['file'] );
  8. Inclusion de plugin : Présence de fichier zip Les plugins ne sont pas autorisés dans les thèmes. Le fichier zip grandnews-custom-post.zip zilla-likes.zip posts-social-shares-count.zip a été trouvé.
Attention
  1. tags du thème : Présence de tags inconnusLe tag black est obsolète, il ne doit pas figurer dans le header de style.css.Le tag white est obsolète, il ne doit pas figurer dans le header de style.css.Le tag responsive-layout est obsolète, il ne doit pas figurer dans le header de style.css.
  2. Text domain : Utilisation incorrecte des fonctions de traduction.Plusieurs text-domain sont utilisés dans le thème. Cela signifie que le thème n'est pas compatible avec les language packs de WordPress. Les domaines trouvés sont grandnews, velvet-blues-update-urls, widget-importer-exporter, grandnews-translation, tgmpa, kirki, envato, wordpress-importer.
  3. Répertoires indésirables : Répertoire de control de version GITA.git a été trouvé.
  4. Eléments custom : Présence d'une entête customAucune référence à custom header n'a été trouvée dans le thème.
  5. Fonctions obsolètes : screen_iconscreen_icon trouvé dans le fichier wordpress-importer.php . Obsolète depuis la version de la 3.8. 1118: screen_icon();
  6. Editor style : Présence de l'édition de styleAucune référence à add_editor_style() n'a été trouvée dans le thème. Il est recommandé que le thème implémente l'édition de style, de manière à faire correspondre le contenu de l'éditeur l'affichage dans le thème.
  7. Image à la une ("Featured image") : Utilisation de the_post_thumbnail() instead of custom fields for thumbnailsAucune référence à the_post_thumbnail n'a été trouvée dans le thème.
  8. Screenshot : Copie d'écranLa taille du screenshot est 880x660px. La taille recommandée est 1200x900, pour prendre en compte les affichages HiDPI. Bien qu'une résolution de 1200x900 soit recommandée, toutes les images au format 4:3 sont acceptables.Mauvaise extension de fichier screenshot ! Le fichier screenshot.png n'est pas un véritable fichier JPG. Le type détecté est : "image/png".
Info
  1. Fichiers optionnels : Présence du fichierde style pour les écritures de droite vers la gauche rtl.cssCe thème ne contient pas le fichier optionnel rtl.php.
  2. Fichiers optionnels : Présence du fichier-template fron-*page.phpCe thème ne contient pas le fichier optionnel front-page.php.
  3. Fichiers optionnels : Présence du fichier-template de page d'accueil home.phpCe thème ne contient pas le fichier optionnel home.php.
  4. Fichiers optionnels : Présence du fichier template de taxinomie taxonomy.phpCe thème ne contient pas le fichier optionnel taxonomy.php.
  5. Fichiers optionnels : Présence de du fichier-template des dates et heures date.phpCe thème ne contient pas le fichier optionnel date.php.
  6. Fichiers optionnels : Présence du fichier-template des pièces jointes attachment.phpCe thème ne contient pas le fichier optionnel attachment.php.
  7. Fichiers optionnels : Présence du fichier-template des images image.phpCe thème ne contient pas le fichier optionnel image.php.
  8. Utilisation d'includes : Utilisation de include ou de de requireLe thème semble utiliser include ou require : config.lib.php 39: require_once(ABSPATH . 'wp-admin/includes/file.php'); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : admin.lib.php 145: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : js-wp-editor.php 35: require( ABSPATH . WPINC . '/class-wp-editor.php' ); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : responsive_css.php 24: require_once(get_template_directory().'/css/grid.css'); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : class-kirki-helper.php 83: require_once( ABSPATH . '/wp-admin/includes/file.php' ); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : class-kirki-control-fontawesome.php 42: include( $json_path ); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : class-envato-wordpress-theme-upgrader.php 11: include_once( ABSPATH . 'wp-admin/includes/class-wp-upgrader.php' );13: include_once( 'class-envato-protected-api.php' ); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
Other checked themes