36
Résultats de validation

Barley

Barley

WordPress 5.7.1 theme
36
  • TYPE DE THèMEThème WordPress %s 5.7.1
  • NOM DU FICHIERbarley.zip
  • TAILLE DU FICHIER2297592 octets
  • MD55c9b166d4dc58de697d599a62ff492bd
  • SHA1572350b71886ec5b4247bb52272e8804ef883eca
  • LICENCEGNU GPL 3
  • FICHIERS INCLUSCSS, PHP, Bitmap images
  • VERSION1.5
  • TAGSright-sidebar, sticky-post, two-columns, three-columns, custom-menu, featured-images, post-formats, translation-ready
  • DATE DE CRéATION2019-12-17
  • DERNIèRE MISE à JOUR DU FICHIER2019-12-17
  • DERNIèRE VALIDATION2019-12-17 04:17
Ce thème n'est peut être pas libre. Themecheck ne distribue pas de thèmes commerciaux.
Alertes critiques
  1. Présence d'iframes : Les iframes sont parfois utilisées pour charger du contenu non désirés ou du code malicieux sur des sites tiers <iframe width="1050" height="591" src="//www.youtube.com/embed/'.$videoID.'" allowFullScreen > trouvé dans le fichier atbs_core.php. 1126: $htmlOutput .= '<iframe width='1050' height='591' src='//www.youtube.com/embed/'.$videoID.'
  2. Menu Admin : Les thèmes doivent utiliser add_theme_page () pour ajouter des pages admin. Fichier theme-option.php : 1576: 'page_parent' => 'themes.php', // For a full list of options, visit: http://codex.wordpress.org/Function_Reference/add_submenu_page#Parameters
  3. Inclusion de plugin : Présence de fichier zip Les plugins ne sont pas autorisés dans les thèmes. Le fichier zip barley-admin-panel.zip barley-extension.zip meta-box-conditional-logic.zip bkninja-composer.zip atbs-sidebar-generator.zip mb-term-meta.zip a été trouvé.
Attention
  1. Eléments custom : Présence d'une entête customAucune référence à custom header n'a été trouvée dans le thème.
  2. Eléments custom : Présence d'un fond customAucune référence à custom background n'a été trouvée dans le thème.
  3. Implémentation de l'internationalisation : Utilisation correcte de ___al(La variable $this a été trouvée dans une fonction de traduction dans le fichier theme-option.php . Les appels de fonctions de traduction ne doivent pas contenir de variables PHP.
  4. Implémentation de l'internationalisation : Utilisation correcte de esc_html__all(La variable $this a été trouvée dans une fonction de traduction dans le fichier theme-option.php . Les appels de fonctions de traduction ne doivent pas contenir de variables PHP.
Info
  1. Fichiers optionnels : Présence du fichierde style pour les écritures de droite vers la gauche rtl.cssCe thème ne contient pas le fichier optionnel rtl.php.
  2. Fichiers optionnels : Présence du fichier-template fron-*page.phpCe thème ne contient pas le fichier optionnel front-page.php.
  3. Fichiers optionnels : Présence du fichier-template de page d'accueil home.phpCe thème ne contient pas le fichier optionnel home.php.
  4. Fichiers optionnels : Présence du fichier template de taxinomie taxonomy.phpCe thème ne contient pas le fichier optionnel taxonomy.php.
  5. Fichiers optionnels : Présence de du fichier-template des dates et heures date.phpCe thème ne contient pas le fichier optionnel date.php.
  6. Fichiers optionnels : Présence du fichier-template des pièces jointes attachment.phpCe thème ne contient pas le fichier optionnel attachment.php.
  7. Fichiers optionnels : Présence du fichier-template des images image.phpCe thème ne contient pas le fichier optionnel image.php.
  8. Utilisation d'includes : Utilisation de include ou de de requireLe thème semble utiliser include ou require : translation.php 9: require_once(get_template_directory() .'/library/$locale.php'); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : bk_theme_settings.php 3: require_once (get_template_directory() . '/library/meta_box_config.php');157: require_once( ATBS_LIBS.'theme-option.php' ); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : bk_inc_files.php 2: require_once (ATBS_INC.'composer/bk_pd_cfg.php');3: require_once (ATBS_INC.'composer/render-sections.php');8: require_once (ATBS_BLOCKS.'featured_slider_module.php');9: require_once (ATBS_BLOCKS.'about.php');10: require_once (ATBS_BLOCKS.'posts_carousel.php');11: require_once (ATBS_BLOCKS.'mailchimp_subscribe.php');12: require_once (ATBS_BLOCKS.'promo_box.php');13: require_once (ATBS_BLOCKS.'category_tiles.php');14: require_once (ATBS_BLOCKS.'posts_listing_grid_fw.php');17: require_once (ATBS_BLOCKS.'posts_listing_grid_first_large.php');18: require_once (ATBS_BLOCKS.'posts_listing_grid.php');19: require_once (ATBS_BLOCKS.'posts_listing_large_grid.php');20: require_once (ATBS_BLOCKS.'posts_listing_list.php');21: require_once (ATBS_BLOCKS.'posts_block_main_col_l.php');22: require_once (ATBS_BLOCKS.'posts_listing_large_grid_fw.php');25: require_once(ATBS_MODULES.'category_tile.php');26: require_once(ATBS_MODULES.'featured_slider.php');27: require_once(ATBS_MODULES.'vertical_3.php');28: require_once(ATBS_MODULES.'vertical_4.php');29: require_once(ATBS_MODULES.'vertical_3_index.php');30: require_once(ATBS_MODULES.'horizontal_1.php');31: require_once(ATBS_MODULES.'horizontal_3.php');36: require_once(ATBS_HEADER_TEMPLATES.'atbs_header.php');37: require_once(ATBS_FOOTER_TEMPLATES.'atbs_footer.php');38: require_once(ATBS_SINGLE_TEMPLATES.'atbs_single.php');40: require_once(ATBS_INC_LIBS.'atbs_get_configs.php');41: require_once(ATBS_INC_LIBS.'atbs_core.php');42: require_once(ATBS_INC_LIBS.'atbs_tgm_activation.php');43: require_once(ATBS_INC_LIBS.'atbs_query.php');44: require_once(ATBS_INC_LIBS.'atbs_cache.php');45: require_once(ATBS_INC_LIBS.'atbs_youtube.php');46: require_once(ATBS_LIBS.'meta_box_config.php');49: require_once(ATBS_AJAX.'ajax-function.php');50: require_once(ATBS_AJAX.'ajax-search.php');51: require_once(ATBS_AJAX.'ajax-megamenu.php');52: require_once(ATBS_AJAX.'ajax-post-list.php');54: require_once(ATBS_INC_LIBS.'atbs_widget.php');56: require_once(ATBS_INC_LIBS.'atbs_archive.php'); Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.Le thème semble utiliser include ou require : atbs_tgm_activation.php 6: require_once( get_template_directory() . '/inc/class-tgm-plugin-activation. Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
Other checked themes